OKTA SAML Atlassian New Integration Setup results in Error

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Problem

You try to setup OKTA SAML for your domain and you have followed every step correctly but still hit the error with "there appears to be an issue with the SAML public key"

You hit this error after all the steps mentioned here at the link http://saml-doc.okta.com/SAML_Docs/How-to-Configure-SAML-2.0-for-Atlassian-Cloud.html has been completed.

  1. You login to the Atlassian URL where you setup the integration to SAML as your domain user 
  2. You seem to get through to the OKTA authentication page 
  3. But then you see an error similar to below 
  4. Checking on SAML Tracer at the Parameters page may hint at certificate mismatch of calculated value versus expected value


Cause

The issue occurs because of the way the public certificate is copied from the OKTA site into the SAML configuration page at Atlassian. It tends to introduce the newline character

Workaround

Copy out the lines into VIM or any editor like Sublime and ensure that the whole certificate is on one line without any space and this should resolve things overall.

Last modified on Jun 5, 2018

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