Unable to Login > User Marked INACTIVE on User Management Page

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Problem

A user in JIRA Cloud and/or Confluence has a status of INACTIVE assigned to his/her account.  This can be seen within the User Management page. 

Diagnosis

Diagnostic Steps

Running the following query will return the status of the user. If 'F' is returned, you know for sure that the user is marked as INACTIVE.

pSQL active query
SELECT active FROM cwd_user WHERE user_name = 'username_here';

Query output

pSQL Output
 crowd=> select active from cwd_user where lower_user_name = 'username_here';
 active
--------
 F
(1 row)

Cause

The root cause is not known at this time but its suspect that:

  • Users were migrated from a Server installation to a Cloud instance while they were marked INACTIVE

Workaround

Always back up your database before performing any modification to the database. If possible, try your modifications on a test server.

Manually update cwd_user database and set user to Active Status:

UPDATE cwd_user SET active = 'T' WHERE user_name = 'username_here';

Resolution

Server Installation:

If you are a JIRA/Confluence Administrator, you can run these commands against your Crowd database.

Cloud Instance:

To resolve this issue please open a support ticket. A support engineer will work with you to establish a 15 maintenance window so that we can apply this fix to your Cloud instance.

Last modified on Feb 26, 2016

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