After a successful server to cloud migration URL links are broken in the new cloud instance

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This pages describes the problem of broken links after migrating from Server or Data Center to Cloud.

What about cloud-to-cloud migrations?

This pages focuses on migrations from Server or Data Center to Cloud. If you have broken links after a cloud-to-cloud migration, you need to reach out to Atlassian Support. To do this, contact Support, and select Migration support. Related feature request

Summary

After migrating Jira or Confluence (Server or Data Center) to Atlassian Cloud, some URLs in the recently migrated products might appear broken as they still point at the old Server or Data Center instances. This includes any links between individual entities in the migrated Atlassian products, for example:

  • Remote links between Jira issues or Confluence pages

  • Links to attachments

  • Links pasted by users as URLs into comments or pages

Cause

After migrating Atlassian products to cloud, they live under different URLs, because they’re essentially new products. Any links from other products (Jira or Confluence) would still reference the old Server URLs, which either no longer work or represent the pre-migration Server instances. Such links aren’t automatically updater after the migration.

To fix such links, you need to complete a post-migration task that updates all broken links to their new cloud destinations.

Solutions

You can update broken links in your migrated products by using the Product links view in admin.atlassian.com.

Before you begin

  • You need to be a site admin of the site where the product lives or an organization admin.

  • You need to be an admin of the product that has links you want to update.

To access this view:

  1. Go to admin.atlassian.com, and select your organization.

  2. Go to Settings > Product links.

  3. For each product that has links you want to update, select … > Update links.

Selecting Update links lets you select new destinations for your links. For details on what data you’ll need to provide, as well as which products and migration types are supported, see the following docs.

Learn how to update product links after the migration

Reaching out to support in case of problems

You should reach out to Atlassian Support only if you encounter problems with the solution described above. In this case, Atlassian Support can use this or a similar legacy way to fix the links for you.

Contact Atlassian Support

To reach out to Atlassian Support, raise a request, and select Migration support.

Provide the data

To update the links in your products, we’ll need information about the destinations of links:

  • Current URL in cloud: URL of the cloud product that will be the new destination for links.

  • Original URL in server: URL of the server product from which it was migrated. If possible, also provide Server ID.

  • (Optional) Production instance URL: If this product was migrated from a staging instance, also provide the URL of the corresponding production instance. If possible, also provide Server ID.

If you’d like to fix links between products in different cloud sites, we’ll also need the URLs of both sites. In this case, you also need to create application links between your products before reaching out to us (for products that live in a single site, app links are created automatically). Learn how to create app links

Types of links that can be fixed

The following lists show the types of links that can be updated. 

Type of link

Example (if applicable)

Remote links to Jira issues or their comments

Links to Jira issues added by users (description, comments)

Remote links to Confluence pages

Links to Confluence pages added by users, including TinyURLs and blog posts:

  • View page (pageID) format

  • Edit page format

  • Page title format

  • Display format

  • TinyURLs, blog posts

Links to Jira source site URLs added by users (description, comments):

  • source-site/browse/

  • source-site/secure/

  • source-site/projects/

  • source-site/issues/

Links to Confluence that use the following URL (usually, this includes links to the space’s main page): <BaseURL>/display/*

-

Links to customer portals in Jira Service Management

https://acmecorp.com/servicedesk/customer/portal/197

Jira Macros need to be fixed separately

Broken Jira macros are different from the types of links described here. To fix them, run the Jira Macro Repair tool on the following URL:

<YourSiteName>.atlassian.net/wiki/admin/jim-validator/view.action

For more info on the tool, see Using the Jira Macro Repair. If you’re unable to fix broken macros, reach out to our Support team.

Any links that aren’t mentioned in the lists above aren’t supported.

Related issues

There are several features in development to either support more links or improve the whole process:

We also have a legacy way of requesting link fixes. If the steps described here don’t work for you, you can try it instead. In some cases, you might also be asked by our Support team to complete it. For more information, see: Legacy way of fixing links.

Last modified on Dec 8, 2023

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