Attachments no Longer Open in Browser Users are Prompted to Download

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

After upgrading to Confluence version 5.1 or newer, attachments files are no longer opening in the browser itself, users are being prompted for download.

Cause

The current behavior (Confluence not allowing attachments to be opened in the browser) is a side effect of a security improvement added to the product. As attachments can be "active content", the behavior in Confluence will not be reverted.

Workaround

1. Click on cog at the Confluence header and choose "Confluence Admin"
2. Under "Users & Security" choose "Security Configuration".
3. Click any of the "Edit" buttons on the page and find the "Attachment Download Security Policy" section.
4. Select the "Insecure: Display all attachments inline" option and click "Save".

Last modified on Feb 19, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.