Blank content when editing a Confluence page
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Upon trying to edit a page, the draft/edit mode is blank or does not correspond to the published version.
Diagnosis
- When editing the page, make sure that no issues happen when trying to add content.
- From the page history, no new version was created after the published one.
- Use the Revert to previous version while editing the page and tap Show changes to ensure that the content has been removed in comparison to the published version.
Cause
When there are no issues with the page's content, this should indicate that the content has been removed (or changed) and was saved as a draft-only. When the Close option is used instead of the Publish one, the published version will not reflect the edit mode's one.
Solution
To retrieve the content back, use the Revert to previous version option:
- Edit the page.
- Tap the ellipsis button at the top-right and select Revert to previous version:
- For the Legacy editor, the Revert to last published version option is located at the bottom-right
- After confirming that the content was removed with the Show changes option, tap the Revert page button: