'Can't connect to your site' error in the Confluence Data Center and Server mobile app
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The Confluence Data Center and Server mobile app throws one of the following errors a user tries to connect it to an existing Confluence server site, or when they are using the app.
Can't connect to your site
This could be because you need to use a VPN, the URL is wrong, or Confluence is unavailable.
Can't connect to your site
We couldn't get a HTTPS connection to your site.
Your site is unavailable or you need to connect to your VPN or network to access it.
Cause
This error appears when the mobile app can't reach the Confluence site at all. This may be because:
- the Confluence site URL entered in the login screen is incorrect
- you've entered the URL with HTTPS, but the site is HTTP (or vice versa)
- HTTPS is enabled, but the Confluence base URL is set to HTTP
- the Confluence site is only accessible when connected to a virtual private network (VPN)
- the Confluence site is currently down or unavailable, for example for scheduled maintenance or upgrade
- your network configuration may be preventing unauthenticated requests to your server
- your proxy server is filtering out headers or cookies required by the mobile app
Resolution
To resolve this issue:
- check that the Confluence site URL has been entered correctly, including the context path if you have one, for example,
mycompany.com/confluence
- try entering the URL without http:// or https:// (we'll try both HTTPS and HTTP for you).
- check whether you can connect to Confluence using the browser on your device.
- make sure you are connected to your organisation's virtual private network (VPN) if your Confluence site is not accessible on the public internet.
- if you only get this error on Android, but you see a compatibility error on iOS, follow this article instead: 'Can't check compatibility' error in the Confluence Data Center and Server mobile app
- check that your proxy server isn't filtering out headers and cookies required by the app. See Problems with logging in because of missing headers or cookies
If you're still unable to connect to Confluence using the Confluence mobile app, talk to your Confluence administrator to check if there is some other reason you won't be able to reach the site from your device.