Cannot Download or View a PDF Document Using IE8

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Symptoms

When trying to download a pdf document from an https address in IE8, the following error message is seen:

The file could not be written to the cache

 

 

 

Cause

This issue occurs if the server sends a "Cache-control:no-store" header or sends a "Cache-control:no-cache" header.  For further information, please review the following Microsoft article http://support.microsoft.com/kb/323308/en-us

 

Resolution

To resolve this issue in Internet Explorer 7 and in Internet Explorer 8, follow these steps:

  1. Start the Registry Editor.
  2. For a per-user setting, locate the following registry key:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    For a per-computer setting, locate the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. On the Edit menu, select Add Value.
  4. To override the directive for HTTPS connections, add the following registry value:
    "BypassSSLNoCacheCheck"=Dword:00000001
    To override the directive for HTTP connections, add the following registry value:
    "BypassHTTPNoCacheCheck"=Dword:00000001
  5. Quit the Registry Editor.
  6. Ensure SSL is set correctly as outlined by this documentation: Running Confluence Over SSL or HTTPS

 

Last modified on Feb 26, 2016

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