Cloud Migration Assistant not working

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Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

    

Summary

When a migration plan is created for a space, hitting the run button changes the status to in progress, and after a few seconds, without showing any errors in the UI, it goes back to run.

Environment

Confluence server and datacenter

Diagnosis

The logs show this error when the assistant tries to check the spaces conflict:

atlassian-confluence.log
2020-09-25 20:56:30,501 ERROR [Caesium-1-2] [service.check.space.SpaceConflictChecker] error Error executing space keys conflict check.
 -- checkExecutionId: 1feef420cee321abf8f04b8e15cde6cd16681468
com.atlassian.migration.agent.okhttp.HttpServiceException: Bad request. Status code: 401, message: {"code":401,"message":"Unauthorized"}

Cause

Since an error 401 means "unauthorized", this means that the assistant tried to reach the cloud instance but the user that was logged in there didn't have the permission to do so.

This can be due to a corrupted browser cache or an unauthorized user logged in while running the migration plan.

Solution

  1. Clear the browser data on the browser where the plan will run;
  2. Make sure that the user logged in in both instances is the site admin account.
  3. Re-link your Server to Cloud. See also MIG-160 - Error executing space keys conflict check which is fixed in CCMA 3.4.3


Last modified on Jan 27, 2025

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