Confluence fails to start on port 80 or 443 with "Permission denied" error in logs

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Confluence fails to start up, and a "Failed to initialize component" error shows in the catalina.out followed by a "permission denied" cause:

catalina.out
12-Mar-2019 16:44:49.905 SEVERE [main] org.apache.catalina.util.LifecycleBase.handleSubClassException Failed to initialize component [Connector[HTTP/1.1-80]]
...
Caused by: java.net.SocketException: Permission denied


Cause

The error above indicates the Tomcat cannot start the server to accept connections due to permissions issues. [Connector[HTTP/1.1-80]] indicates Confluence is attempting to start on port 80, which is often restricted for security purposes on many operating systems.

Resolution

There are two options for resolving this:

  • Run Confluence on a non-restricted port, such as 8090 (the default port for Confluence)
  • Install a reverse proxy to redirect requests from port 80 and 443 to the internal server. For recommended reverse proxy configurations, see the articles linked from Proxy and HTTPS setup for Confluence.


DescriptionExplanation of why an application server might not start up on port 80
ProductConfluence Jira
Last modified on Jun 13, 2019

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.