Confluence not accessible after apparent clean startup in the logs
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Confluence seems to start normally in both the atlassian-confluence.log as well as catalina.out.
When you connect to the server housing Confluence you see the following in the catalina.out
It is best to try to connect to the machine using it's IP
org.apache.catalina.core.StandardHostValve custom
SEVERE: Exception Processing ErrorPage[errorCode=500, location=/500page.jsp]
java.lang.NullPointerException
at org.apache.catalina.loader.WebappClassLoader.findResourceInternal(WebappClassLoader.java:2963)
at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2753)
at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1159)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1647)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1526)
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
...
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
at java.lang.Thread.run(Unknown Source)
Diagnosis
Run "netstat -an | grep LISTEN" command on the Confluence Server. There appears to be nothing Listening on port 80 or 8090
Run "wget http://localhost:8090" see that we are returned the same 500 error we see in the catalina.out
Run sudo iptables -L. Note that there are redirect rules in place.
Cause
IP table redirects have ceased functioning as expected
Resolution
- Disable IP tables redirects with the following Command
- iptables -F
Recreate your IP Tables following our document on how to perform this operation