Confluence Service fails to start after upgrading Confluence in a Windows environment
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After upgrading Confluence on Windows, the Service fails to start and shows the following error in a pop-up:
Error 5:Access is denied
Environment
After Confluence is upgraded to version 7.19.17, 8.5.5
OS - Windows
Diagnosis
- A Confluence upgrade has been completed successfully.
2. However, the Confluence Service does not start and throws the below error:
Cause
Confluence cannot start because the Network Service account lacks the necessary permissions for the installation directory and home folders.
Required permissions :
Solution
Please update the directory permissions in Confluence according to the instructions provided below.
- Login as admin
- Run the following steps for the NETWORK SERVICES user:
- Right-click on the Confluence Home/Installation directories
- Click Properties
- Click the Security Tab » Advanced
- Tick "Replace all child object permissions with inheritable permissions from this object."
- Apply the changes
In case the user with which you are logged in does not have full permissions for the Confluence installation and home directories, you might encounter the below issue when trying to follow the above steps:
In this case, ensure that the user applying the permissions has Full Access rights to the directories.