Daily backup is broken after server migration
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the server and data center platforms.
Problem
- Confluence was migrated from a different server that enforces strict file permission
Daily backup failed with the following error in the
atlassian-confluence.log
:2011-02-16 13:08:33,092 ERROR [http-8090-1] [atlassian.confluence.servlet.ConfluenceServletDispatcher] sendError Could not execute action -- referer: http://<confluenceURL>/confluence/admin/backup.action | url: /confluence/admin/dobackup.action | userName: admin java.io.IOException: Permission denied at java.io.UnixFileSystem.createFileExclusively(Native Method) at java.io.File.createNewFile(File.java:883) at com.atlassian.core.util.FileUtils.copyFile(FileUtils.java:465) at com.atlassian.core.util.FileUtils.copyFile(FileUtils.java:401) at com.atlassian.confluence.importexport.actions.BackupAction.execute(BackupAction.java:79) :
In confluence.cfg.xml, custom folder location for daily backup is disabled:
<property name="admin.ui.allow.daily.backup.custom.location">false</property>
- Manual backup works fine
<Confluence Home folder>/backups
belongs to the correct Confluence user and contains the correct file permission:drwxr-xr-x 2 confluence staff 68 18 Feb 08:20 backups
Diagnosis
- Check for Confluence backup path in http://<confluence url>/admin/dailybackupadmin.action and you will notice it is set to a different folder - this, despite that custom directory location is disabled.
- Check what is the <backupPath> value stored in the database.
select BANDANAVALUE from BANDANA where BANDANAKEY = 'atlassian.confluence.settings';
Resolution
Set the setting to true again in
confluence.cfg.xml
:<property name="admin.ui.allow.daily.backup.custom.location">true</property>
- Restart Confluence
- Go to
http://<confluence url>/admin/dailybackupadmin.action
and edit the setting. Change the location to what it should be.
Related Content
See Also