"Instance health checks" screen is blank in Confluence Datacenter
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
"Instance health checks" screen under Troubleshooting and support tools is empty/blank after completing a Confluence Upgrade
Environment
Confluence 7.19
Diagnosis
In the atlassian-confluence.log
file, you will find the following error message:
2023-08-16 02:18:58,256 ERROR [http-nio-8090-exec-62] [troubleshooting.healthcheck.impl.DefaultSupportHealthCheckManager] runAllHealthChecksInBackground Unable to start the health check process
-- referer: https://CONFLUENCE_URL/plugins/servlet/troubleshooting/view/ | url: /rest/troubleshooting/1.0/check/process/ | traceId: a02ed9efac023d6f | userName: admin
com.atlassian.activeobjects.internal.ActiveObjectsInitException: bundle [com.atlassian.troubleshooting.plugin-confluence]
...
Caused by: com.atlassian.activeobjects.internal.ActiveObjectsSqlException: There was a SQL exception thrown by the Active Objects library:
Database:
- name:Oracle
- version:Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production
- minor version:0
- major version:19
Driver:
- name:Oracle JDBC driver
- version:12.2.0.1.0
java.sql.SQLSyntaxErrorException: ORA-00955: name is already used by an existing object
...
Caused by: Error : 955, Position : 16, Sql = CREATE SEQUENCE "AO_4789DD_SHORTENED_KEY_ID_SEQ" INCREMENT BY 1 START WITH 1 NOMAXVALUE MINVALUE 1, OriginalSql = CREATE SEQUENCE "AO_4789DD_SHORTENED_KEY_ID_SEQ" INCREMENT BY 1 START WITH 1 NOMAXVALUE MINVALUE 1, Error Msg = ORA-00955: name is already used by an existing object
Cause
Confluence is trying to create sequence for the AO table(s) which is used by the Troubleshooting and Support Tools plugins.
The sequence is available in the database but due to some permission issue, it was not linked to the correct schema owner. This happens when restoring the database dump in Oracle. The sequence requires the correct schema owner including case sensitive name. This results in Confluence attempting to recreate the sequence but failing to do so because the sequence name exists under a different schema owner.
Solution
Please, follow these steps to address the situation:
Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
- Stop Confluence
Drop the affected sequence in the database side
DROP SEQUENCE AO_4789DD_SHORTENED_KEY_ID_SEQ;
- Start Confluence again.