Jira Macro Filter displays no issues in Confluence
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The following appears in the page:
Diagnosis
This issue happens when you add a Jira issue and you can't view it in Confluence.
Cause
It happens when the following parameters are in jira-config.properties or jpm.xml:
jira.search.views.max.limit = -1
jira.search.views.default.max = -1
Resolution
- Shutdown Jira
- Open the
jira-config.properties
file (located at the root of your JIRA Home Directory) in a text editor.
This file may not exist if you are using a new Jira installation or an upgraded Jira installation where your previous Jira version(s) had never been customized. - If you don't have
jira-config.properties
file, you need to open JIRA jpm.xml file which is located at<jira-application-dir>/WEB-INF/classes/jpm.xml
Find for the following parameter in the file
jira.search.views.max.limit = -1 jira.search.views.default.max = -1
and change it to
jira.search.views.max.limit = 1000 jira.search.views.default.max = 1000
Save the file
Restart Jira
For more information read Limiting the number of issues returned from a search view such as an RSS feed.