Login Screen Loops Back To Login Screen With No Error When Using Correct Username And Password
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When logging into Confluence you are sent back to the login screen with no error.
Causes
- The browser cache has two values for
JSESSIONID
or if using Crowd, extra values forcrowd.token_key
. - A software application firewall is blocking Confluence.
- Multiple Atlassian products are using the same IP Address or hostname, and the same context path, but are listening on different ports. Due to the way the browser stores cookies, their session cookies step on each other, and sometimes that can lead to this issue happening.
Resolution
Cause one
- Clear your browsers cache and reconnect to Confluence.
Cause two
- Ensure there are no software firewalls blocking Confluence and the cookie
JSESSIONID
.
Cause three
- Change the context path of the different Atlassian products so that they are no longer using the same context path, see Logging into another Atlassian application logs me out of Confluence for more information.