Multiple problems due to file system permissions configuration
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
A wide variety of symptoms can occur, including:
- Unable to update or license key. One of the most common errors to appear is "The license you entered was not valid"
- Unable to upload attachments.
- Unable to move or copy pages with attachments.
- Unable to install Confluence.
- Indexer not updating. For more details: See here.
The following appears in the atlassian-confluence.log
:
2008-02-28 03:41:24,372 ERROR [TP-Processor2] [opensymphony.webwork.dispatcher.ServletDispatcher] serviceAction Could
not execute action -- url: /confluence/setup/dosetuplicense.action | userName: anonymous
com.atlassian.config.ConfigurationException: Couldn't save confluence.cfg.xml to /export/confluence/data directory.
at com.atlassian.config.xml.AbstractDom4jXmlConfigurationPersister.saveDocument
(AbstractDom4jXmlConfigurationPersister.java:75)
at com.atlassian.config.xml.DefaultDom4jXmlConfigurationPersister.save(DefaultDom4jXmlConfigurationPersister.java:23)
...
Caused by: java.io.IOException: Permission denied
at java.io.UnixFileSystem.createFileExclusively(Native Method)
at java.io.File.createNewFile(File.java:850)
If you cannot create attachments, something like this may appear in the atlassian-confluence.log
ERROR [http-8080-9] [confluence.pages.thumbnail.DefaultThumbnailManager] getThumbnailsFolder Containing folders
/data/confluence/data/thumbnails/34677261 for the attachment test.png could not be created
Cause
This is caused by a problem with the directories' permissions. Users are not granted the necessary permission to access the directories.
Resolution
Grant all Operating Systems permissions for the user running Confluence to access the confluence-home
and confluence-install
directories. Refer to Confluence Home and other important directories for the location of the confluence-home
directory.
If you are still getting java.io.UnixFileSystem.createFileExclusively although the permissions are all set and it occurred when trying to generate an XML backup, you are hitting this bug instead: CONF-28575 - Getting issue details... STATUS