Pages Stuck on Loading Screen When Using Confluence Mobile
This article is about Confluence mobile web. It does not apply to the Confluence iOS app, which is available now for Confluence Cloud customers.
Symptoms
On occasion, when using Confluence Mobile, a user will navigate to a page and it will see a spinning loading page. This loading page will never finish.
Cause
There is reproducible bug that can cause this, specifically the user is accessing a page that includes certain macro elements after visiting a page that does not include those elements.
Workaround
Go to Admin > Cache Management > Show Advanced View
To get Confluence Running again flush:
- Web Resource Keys And Condition State Set
- Web Resource Keys Condition List
- Try reloading the page, it should load properly
You can simply flush the cache every time a user encounters the issue, or you can do one of the following:
- Set Web Resource Keys Condition List cache to 1, return the value to 1000 after the bug is fixed
- This will affect performance on larger Confluence instances, and you will on occasion have users get a frozen page (a refresh should load the page at this point)
- Remove all note macro elements from Confluence
- Perform a search for "macroName: X" without the quotes, where X is the name of the macro. This will return all pages that have the macro in them.
- Manually remove the macro
Resolution