Personal Space import fails with 'A personal space already exists for user ~'

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Importing a Personal Space backup fails with the following error message:

A personal space already exists for user ~


Example screenshot:

Environment

Confluence Cloud

Diagnosis

Confirm if a Personal Space already exists for the affected user.


This can be done by clicking on Spaces > View all spaces and finding the user's First and Last Name.

As an alternative, we can use the direct URL to the user's Personal Space:

  1. Copy the alphanumeric value from the error message (including the ~ symbol);
  2. Copy the following URL:
    https://<DOMAIN>.atlassian.net/wiki/spaces/~/overview
  3. Replace <DOMAIN> with your own domain's name;
  4. Replace the ~ symbol with the value copied from the Import screen;
  5. Hit Enter to navigate to the URL.

Example: https://<DOMAIN>.atlassian.net/wiki/spaces/~5e79d70d534b3c0c42c2ea0f/overview


Cause

Confluence will prevent any Spaces to be imported if the Space Key matches an existing Space to avoid overwriting any data.

This is mentioned in Import a Confluence Cloud space:

(warning) The space importer does not overwrite existing spaces, so if your Confluence instance already has a space with the same space key as a space you are trying to import, Confluence will not be able to import that space.

Example: trying to import a Space named "Charlie of Atlassian" with a Space Key of 'CA' will be blocked if another Space already exists with a matching Space Key of 'CA', for instance "Customer Advocates".

The same logic applies to Personal Spaces, however the Space Key will be an alpha-numeric string that matches the UserID in this case.

Solution

Delete the user's Personal Space, then re-attempt to import the backup.


If the user doesn't have a Personal Space, the following message will be displayed:

We couldn't find what you're looking for

We looked everywhere, but it doesn't exist. It may have been deleted. Unless, of course, the URL has a typo in it ;)


Example screenshot:

In this case, importing the Personal Space from a backup should work just fine.

If the Personal Space was deleted but the Import is still failing, please open a Support ticket with us via https://support.atlassian.com/contact/ .


Last modified on Aug 22, 2023

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