Side Bar and Top Bar Menu items are missing when using Chrome or Internet Explorer

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Scenario 1:

When viewing a page, certain page elements do not render when using Chrome, such as:

  • The menu items in the side bar
  • The menu items in the top menu bar
  • Table of Contents macro contents
  • Team Calendars macro contents

 

Problem is not reproducible in other browsers such as Firefox or Safari

Nothing appears in the atlassian-confluence.log

Scenario 2:

After Confluence upgrade similar issue identified in Internet Explore: 

Diagnosis

Diagnostic Steps

There are multiple reasons why page elements may not render. This KB highlights one specific case, but the steps below will help you troubleshoot if the problem is in the client-side (e.g. in the browser). If the problem only occurs in a single browser, the problem is very likely to be a browser-specific issue rather than a server-side problem with Confluence.

  1. In Chrome, click the browser's Menu icon on the upper right > More Tools > Developer Tools
  2. Go to the Console tab in the Developer Tools panel
  3. Navigate to a page that is exhibiting problems with rendering
  4. If you see errors like the below in Chrome's Console panel, then continue to the Cause and Resolution sections:

    RangeError: Maximum call stack size exceeded

Cause

  • One or more plugins are causing the Chrome's stack size limit to be exceeded when loading the page.
  • User installed plugin caused this issue in IE.

Workaround

  1. In a staging environment, or during a maintenance window, place Confluence into Plugin Safe Mode via Confluence Admin > Manage Add-Ons > Safe Mode. This will temporarily disable all user-installed plugins
  2. Confirm that the page can now load correctly (minus any plugin functionality)
  3. Re-enable the plugins one-by-one until the problem can be reproduced again to determine the problematic plugin.
  4. Exit safe mode and then disable only the problematic plugin
  5. Follow up with the plugin vendor to see if there is a permanent resolution

A few of the plugins that have been reported to cause this issue:

  • ServiceRocket Composition Plugin
  • Plugins that provide custom theming
  • Comala share it plugin (For IE)


Last modified on Sep 14, 2020

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