Space import finished with no errors but the space seems to be empty

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Symptom

  1. Export a space from original site in XML format.
  2. Import that file to the target site.
  3. Access that space.

The space exists, but the page tree doesn't show up; unable to find the pages included in that space.

This is expected behavior and not a bug, caused by restrictions. 

Diagnosis

Diagnostic Steps

Check whether there's a restricted page in the following steps:

  1. Access the imported space in the target site.
  2. Navigate to Space settings > Permissions > Restricted Pages.
  3. Check any page names appear or not.

Cause

The source space has a restricted page/s (in this screenshot, the Overview page is restricted) which is inherited at the target site.

Resolution

Remove the restriction and set it again as needed.

  1. Access the imported space at the target site
  2. Navigate to Space settings > Permissions > Restricted Pages
  3. Click each lock icon to remove the restriction
    1. Note: if the account is a space admin which isn't included in the site-admin group, some error messages will show up. Even in this situation, the restriction is properly removed and you can confirm this by refreshing the "Restricted Pages" page.
  4. If needed, access each page and apply the required restrictions again

Last modified on Mar 28, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.