Spinning wheel loads forever while creating Personal Space

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Symptoms

This behavior happens because the personal space is not mapped to the correct user even when the space key is exactly the same as the username. For example, spacekey = ~admin and username is admin. When admin user click its profile picture at the top right to bring down the tools section, "Add Personal Space" button appear that confirmed admin user doesn't have personal space associated with it yet even when it exist as can be seen in the screenshot below:

This behavior shows up after users restore a xml backup from another instance, this is a know BUG which we are tracking at  CONF-34686 - Getting issue details... STATUS .

Diagnosis

Please execute this SQL query to confirm that you are encountering this issue:

SELECT * FROM SPACES WHERE SPACEKEY like '%~%' AND CREATOR IS NULL;

If the query above returns with result please proceed to the resolution below. Otherwise, create a support ticket in https://support.atlassian.com to get assistance.

Resolution

Make sure to backup your Confluence database.

  1. Shutdown Confluence.
  2. Please execute the SQL query provided in the diagnosis section

    SELECT * FROM SPACES WHERE SPACEKEY like '%~%' AND CREATOR IS NULL;
  3. Take note of the spacekey returned by the above SQL queries. Remove the '~' from the space key to get the user name of the personal space owner

  4. Execute this SQL query to find the user_key of the user

    SELECT * FROM user_mapping WHERE lower_username = '<Insert user name>'
  5. Once the user_key is found, please execute this SQL query

    UPDATE SPACES SET CREATOR = '<Insert User Key obtained from step 4>' WHERE spacekey = '~<insert username>';
  6. Start Confluence.
  7. Access "Cache Statistics" from "Confluence Administrator" menu and click "Flush All"

Last modified on Feb 26, 2016

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