Synchrony process doesn't stop with Confluence in AWS

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When Confluence is stopped, the process of Synchrony still keeps on lingering around. 

Environment

The issue is known to happen when Confluence is being managed via AWS Associations (Systems Manager State Manager). Usually happens when Synchrony is managed by Confluence as opposed to starting and stopping Synchrony manually by admins.

Diagnosis

It's important to understand how Confluence is being run. Like via service (systemd) or started manually via batch script start-confluence.sh. When Confluence is started via AWS associations, some of the other scripts involved in start/stop of Confluence like user.sh are not invoked properly and it can hinder the shutdown process of Synchrony. We can also see error messages like follows in AWS SSM agent.

Feb 10 21:12:30 ab-121231 amazon-ssm-agent: "standardError": "/usr/bin/stopConfluence: line 16: /usr/bin/user.sh: No such file or directory\n"

To verify the issue, start and stop manually via start/stop-confluence.sh and see if the issue persists. 

Last modified on Mar 2, 2021

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