Synchrony service won't start due to "java.lang.NumberFormatException"

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Synchrony process won't start either with Confluence or manually.

The following error appears in the atlassian-confluence.log

ERROR [Long running task: Restart Synchrony Task] [plugins.synchrony.tasks.AbstractConfigLongRunningTask] runInternal An error occurred when running a Synchrony ConfigLongRunningTask
 -- url: /rest/synchrony-interop/restart | referer: http://mycompany.com/admin/confluence-collaborative-editor-plugin/configure.action | traceId: 4e06227767fccf2b | userName: XXXXX
java.lang.NumberFormatException: For input string: ""

Cause

Synchrony PID file has been corrupted.

Resolution

The PID file is created when starting Confluence, in case it doesn't already exist. The steps below will fix the issue:

  1. Stop Confluence 

  2. Remove the file <confluence-install>/temp/synchrony.pid

  3. Start Confluence


DescriptionSpecific error message appears in the logs when attempting to start synchrony
ProductConfluence
Last modified on Jun 14, 2019

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