Unable to add users into Space Permission page

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Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Some users are not able to be added into Space Permission page. Searching for the user's username in the field provided yields no result, only an error message of "No matches found":

However the user exists from the User Directory. No errors displayed in the atlassian-confluence.log.

Diagnosis

Issue most commonly reported after an upgrade to 5.9.x and above

Cause

Cause 1 - User does not belong in any group that has a "can-use" permission

Issue could also be caused by this particular user does not belong to any group that has a "can-use" permission. This can be checked by going to the user's details from User Directory > Search for this user > Click on the user's name to obtain the lists of groups that this user belongs in:

In this example, the user does not belong to any group. Should the user belong to some group, check if any of the group that the user belongs to has the "can-use" permission. The list of groups that has a "can-use" permission are listed in the Confluence Admin > Global Permission:

In this example, the groups that has the "can-use" permission are only confluence-users and confluence-administrators.


The reason that users that does not belong to any "can-use" permission are unable to be given space permission is because there is no support for individual user-level space permissions for unlicensed users. Permissions inherited from groups are also prevented for unlicensed users. When a user is unlicensed, only the permission for all unlicensed users is checked. This is covered in the following Closed Bug Report:

Cause 2 - Indexing issue

Issue with unable to search specific content - or users, are commonly caused by indexing issue. Indexing could be broken due to Upgrade or Migrating task. Please see Resolution 2 to remedy this.

Resolution

Resolution 1 - Add users into groups that has the "can-use" permission

Go to User Directory > Search for this user > Click on the user's name > Edit Groups > Give this user an appropriate group.

Resolution 2 - Perform content indexing

Perform rebuild search index from the admin console or rebuild indices from scratch


Last modified on Dec 5, 2024

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