Unable to download plugins, and getting the error message "This version of Confluence is unrecognized by the Atlassian Marketplace. It might be a non-standard build or be too new to appear."

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Problem

The following issues appear in the Manage apps / Manage Add-ons page:

  • Unable to download any apps.

  • Getting the following error message: "This version of Confluence is unrecognized by the Atlassian Marketplace. It might be a non-standard build or be too new to appear."

Causes

  • The version of Confluence is too new (EAP versions).
  • The version of Confluence has been withdrawn.
  • The version of Confluence was an internal release.
  • The version of Confluence was an OD version 6.0.0-OD-2016.10.3-1082 and above

Diagnosis

Check if the version that you have is one of the above by comparing from the following release list: Confluence Release Notes

  • For example, Confluence 6.15.3 and 6.15.5 are listed as "was withdrawn" and therefore will be affected by this issue.

Resolution

Upgrade to the next available version or manually install the desired plugin via Installing Marketplace apps -Installing by file upload

DescriptionGetting the error message that Confluence is unrecognized by the Atlassian Marketplace
ProductConfluence

Last modified on Jul 16, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.