Unable to edit any pages in Confluence due to Collaborative Editing
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After a new installation or an upgrade to Confluence, users are no longer able to edit any pages. The following error messages may appear in a pop-up error dialog:
Loading the editor's taking longer than usual. Give it a few moments, then refresh your page if it still doesn't load. Speak to your Confluence admin if that doesn't fix it.
This page is taking longer to load than usual. Give it a few moments, then try refreshing. Still having issues? Contact your Confluence admin.
Environment
- Confluence Server or Data Center
- Release 6.x or greater
Cause
The Synchrony process that enables Collaborative Editing is unreachable by the end-user's browser.
Resolution
Step #1 - Access URL and base URL match
With Collaborative Editing in place, it is very important to ensure that both the access URL and server base URL of the instance are identical. A mismatch of Base URL and Access URL will result in users unable to edit any pages. Please ensure that this has been checked off the list. Please take note of the protocol (http or https) that Confluence is using. Go to Confluence Admin > General Configuration to check Confluence's Base URL:
Step #2 - Restart Synchrony
Navigate to Confluence Administration > General Configuration > Collaborative Editing and click on "Restart Synchrony".
Afterward, try to create a new page or edit an existing one and see if the issue is resolved. If not, proceed to the next step.
Step #3 - Check to See if Synchrony is Running and Accessible locally
- For Window Server instances, open http://localhost:8091/synchrony/heartbeat in a browser on the server
For Linux distributions run:
curl -i http://localhost:8091/synchrony/heartbeat
The results should be the text OK
If this fails, check the following:
- Is the Collaborative Editing disabled under Confluence Administration » General Configuration » Collaborative Editing?
- Is the java Synchrony process running?
- Windows: check the Details tab of the Confluence process in Task Manager
- Linux:
ps -ef | grep -i synchrony.core | grep -vi grep
- Windows: check the Details tab of the Confluence process in Task Manager
- Is Synchrony listening on the port it is binding on?
Step #4 - Review proxy configuration (If applicable)
There is additional configuration that must be done within the proxy configuration file in order to make it work with Collaborative Editing. Below is the relevant documentation you can use for reference:
Note that changing the files mentioned in either of the KBs above requires a proxy restart. Pay special attention to the sections that are specifically for Confluence 6.
Here's a quick proxy troubleshooting checklist provided in this documentation: Troubleshooting Collaborative Editing
If you have configured your reverse proxy, but can't edit pages, here are some things to check in your configuration:
- Go to
installation-directory>/conf/server.xml
and check theConnector
directive. Make sure that you have correct values for<protocol>
and<proxyName>
. See the examples in the guides above for more information. Note that these are case sensitive. - If you're using Apache, check the order of the Confluence and Synchrony directives and location blocks in the proxy config file. See the examples in the guides above for more information.
- If you're using Apache, make sure you're using Apache 2.4 (with WebSockets support) and all required modules have been enabled (
mod-proxy
,mod_rewrite
,proxy_wstunnel
).
If you are not using a reverse proxy, and can't use Confluence's internal Synchrony proxy for some reason, please make sure port 8091 is open and available for Synchrony to use (or change the port that Synchrony runs on).
Proxy, SSL, and any network configuration is not part of our support scope as per Atlassian's Support Offerings. Any effort provided to support issues related to proxy or SSL configuration will be on a best-effort basis by the support engineer.
Step #5 - Forward proxy configuration (If applicable)
In Confluence 6 onwards, we need to explicitly include 127.0.0.1
as part of the http.nonProxyHosts
and https.nonProxyHosts
setting to ensure Synchrony can work properly. This is mentioned in our documentation Configuring Web Proxy Support for Confluence:
If you're using Confluence 6.0 or later with Synchrony, you'll need to pass the following to ensure Confluence can connect directly to Synchrony. Replace localhost|127.0.0.1 with your Synchrony IP if you have used the
synchrony.host
system property to change the IP Synchrony uses.-Dhttp.nonProxyHosts=localhost\|127.0.0.1 -Dhttps.nonProxyHosts=localhost\|127.0.0.1
It is insufficient to include only localhost as the IP address 127.0.0.1
needs to be explicitly defined. These changes are either made in your system property or they can be found in catalina.properties
- depending on where you defined them. Restart Confluence after making these changes and observe to see if the issue still persists.
Step #6 - Enable safe mode
While Collaborative Editing is set to On, enable safe mode and see if the issue persists. This way, we can eliminate third-party add-ons as one of the possible causes of the issue.
Enabling safe mode will disable all of your user-installed add-ons at one go. It is a good troubleshooting method to determine if an issue is caused by a third-party add-on or not. If it is, you can also easily identify which one is the culprit by enabling them one by one and observing when the issue occurs again.
Afterwards, try to create a new page or edit an existing one and see if the issue is resolved. If not, proceed to the steps below where applicable.
Step #7 - Turning off Collaborative Editing and Contacting Support
Gather the following to provide to support:
- Details of any networking configuration that Confluence is running on, with its configuration files.
- Generate a HAR file while replicating the issue with the editor not loading or page not saving. This will capture all requests and responses between the browser and server.
- Create a full Support Zip so that we can cross check the logs with the requests and timestamps contained in the HAR file.
If this is occurring in your production environment, Switch off Collaborative Editing temporarily in order to ensure your users can continue using the wiki site as per normal. Refer to Administering Collaborative Editing for full documentation of this feature and its modes.
Use this as a temporary workaround for the time being to minimize disruption to your business processes. Turning Collaborative Editing off falls back the editing and saving mode to what it was in Confluence 5.x.
To disable it, Navigate to Confluence Administration > General Configuration > Collaborative Editing > Change mode and select "Off". After changing modes, all users should be able to edit and create new pages now.
Other common issues
Other common issues that contribute to Collaborative editing issues are:
- Port 8091 is unavailable
- Websocket issues
- Memory issues
- Multiple Synchrony processes
- Incompatible browser extensions
- Too many people in the editor
Notes
As a best practice, it's recommended to have a staging environment that is separate and identical to your production environment on which we can do troubleshooting on. This is so we can ensure minimal disruption to your production, as all changes are first applied to your staging environment.