Clone Issue Is Not Available For Any Issues
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The "Clone" option does not show up under the More menu for any JIRA issue.
Cause
Please note that DB access and access to System Add-Ons is restricted to Sysadmin users, and will need to be done by Atlassian Support if you are in the Cloud environment. Please file a support Request at https://support.atlassian.com
It's possible to disable this using a workflow property, jira.permission.create.clone = denied. You can review your workflow, or via the database:
select * from jiraworkflows where descriptor like '%permission.create.clone%';
That will return any workflows that have this property setting.
Also, there is a System Add-On, Issue Operations Plugin, which has a module called View Issue Ops Bar Clone Link, which controls whether the Clone option is available for the entire instance, and needs to be enabled to allow Cloning.
Resolution
If Workflow properties are set to restrict this, they must be removed from the Workflow. If you know where these settings are, you can do so through the UI, but if you do not, the DB query above will identify those workflows that need to be changed.
If the plugin module was disabled, you can just enable that module to make the Clone option available on all issues.