Development Panel missing when viewing an issue in Jira
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
JIRA Software has been integrated with DVCS or an Application Link but the Development panel and the "Create Branch" are not shown on the issue. Additionally:
- "Create Branch" option under the "More" issue operation is also missing.
- All issues and projects are affected
- JIRA Software has been integrated with Fisheye/Crucible but the "Development panel" is not displayed.
Note: The Development panel will not appear if there are no meaningful actions or development information for that issue.
For GitLab integration: The Development Panel does not show the Create Branch functionality when integrated with GitLab via DVCS. Thus, if no commits, branches, or pull requests reference an Issue the Development Panel may not appear:
From GitLab Jira development panel integration:
- "Creating a branch is only supported by the GitLab for Jira app and is not available within the DVCS integration. See officially supported DVCS features for more information."
Example:
Cause
This can be caused by one of the following:
- Development Integration Plugin may be disabled.
- The application link to Bitbucket Server may not have OAuth configured such that JIRA Software can make outgoing 2-legged OAuth requests, and Bitbucket Server can receive incoming 2-legged OAuth requests.
- This can occur if JIRA Software was started at a time when Bitbucket Server or Fisheye was not started yet, which means the capabilities cache will be out of date.
- Capabilities Warning can't be refreshed due to a Proxy config
- The user may not have sufficient permissions to view the Development panel.
- Some configuration on the Bitbucket Server's end may cause the Development panel not to render correctly.
- There may be an invalid SSL certificate, as seen in Development Panel missing and Workflow triggers not working.
- The user does not have the Developers role from the Users page
- The Fisheye/Crucible review is in the "Draft" status
- A third party add-on has broken page rendering
Resolution
Cause 1
Navigate to Administrations > Manage Add-ons > All add-ons > enable the Development Integration Plugin and all of its modules.
This plugin is available from JIRA 6.2+
- Navigate to Project > Administration > Development tools and address any warnings that might appear there.
Cause 2
- Follow the OAuth Troubleshooting Guide and ensure that the application link is configured with 2-legged OAuth on both ends.
Cause 3
Go to "Development Tools" under the project's administration, and click "Refresh" on the connected application.
Take note that WebSudo is required for Refresh to work: JRASERVER-41368 - Prompt for Administration Access when Refreshing Development tools
Cause 4
If Resolution for Cause 3 does't work, check if the proxy config for JIRA is using a Cache-Control header e.g. (for Apache):
Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
This specific header is known for causing Capabilities Warning. Disable the header and restart the proxy server in that case.
Cause 5
- Navigate to
Your Project > Administration > Permissions.
Change the permissions for View Development Tools to include the necessary users.
This will affect all projects with the same permission scheme.
Cause 6
Check the Capabilities Warning Applications with flagged capabilities may be offline or older versions KB to ensure everything is properly configured.
Cause 7
Ensure the FQDN(Fully Qualified Domain Name) in SSL certificate matches JIRA Software and Bitbucket Server hostnames.
Cause 8
Check the View Project Roles for User to ensure that the user has the Developers role for the appropriate projects :
Cause 9
- Start the review
- the development panel will be displayed with the related review
Cause 10
- Tempo Timesheets 8.0.0 is known to cause this problem, version 8.1.3 confirmed to work fine.