Error while creating issues via Timeline in Jira
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When creating issues in Jira using the Timeline feature, one may encounter errors. A common error is:
The value '<MISSING_ISSUE_TYPE>' does not exist for the field 'type'.
Environment
Jira Cloud
Diagnosis
Upon reviewing the browser HAR logs, the following error may be observed in the API call which is failing:
"errors": [
{
"message": "The value '<MISSING_ISSUE_TYPE>' does not exist for the field 'type'., The value '<MISSING_ISSUE_TYPE>' does not exist for the field 'type'.",
"extensions": {
"__typename": "RoadmapMutationErrorExtension",
"statusCode": 400,
"errorType": "Bad Request"
}
}
Additionally, when inspecting the payload for this request, the following can be seen:
"operationName": "addRoadmapItemMutation",
"variables": {
"sourceARI": "ari:cloud:jira-software:d1825e56-4480-4f86-a4av-a322g9xa8v4c:board/87",
"input": {
"projectId": "10058",
"itemTypeId": "10002",
"parentId": "13805",
"summary": "test",
"dueDate": null,
"startDate": null,
"color": "PURPLE",
"jql": "project = ABCD\nAND type IN (subTaskIssueTypes(), Epic, Task, Meeting, <MISSING_ISSUE_TYPE>, Sub-task, <MISSING_ISSUE_TYPE>)\nORDER BY Rank ASC",
"jqlContexts": []
},
"isRoadmapsCriticalDataItemFlaggedEnabled": false
}
Cause
This error occurs when the JQL query in the board filter contains the missing issue types. These issue types may have been deleted or renamed, leading Jira to be unable to locate them in the JQL, resulting in the error.
Solution
To resolve this issue, the board's filter JQL must be updated to exclude the missing issue types. Follow these steps:
- Log in to the Jira instance and navigate to the project board where the error is occurring.
- Click the three dots in the top-right corner and select Configure Board.
- In the board's General Settings, go to the Board Filter section and click Edit filter query. This will redirect to the filter edit page.
- Remove the missing issue types from the filter, then click Save Filter.