How to forcefully rotate the application logs
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Occasionally, the log4j log rotation process may encounter failures, leading to the continuous expansion of application logs. In such cases, it may become necessary to manually force a log rotation to address the size-related concerns effectively.
Environment
All versions are impacted
Cause
Whenever a logging operation is initiated, the log file will be automatically locked to maintain the integrity of the log data. In the event of performance issues leading to prolonged execution of the log operation or if the writing process encounters significant delays, it is possible for the log rotation event to time out, resulting in continuous growth of the log files.
Solution
- From the top navigation bar select Administration System. >
- Select System support > Logging & Profiling to open the Logging page.
- At the Mark Logs section, select Log Rollover and type a message in the Optional Message box signifying the log rollover.
- Click Mark.
The log rotation process has been completed successfully. If you encounter any issues with the rotation, performing a restart of Jira will be necessary to remove any lingering locks on the log file.