JWM Board is loading as Empty Board

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary


The Jira Work Management board is empty and generating a 500 error code when attempting to load the workflow in the Development tools

Environment

Jira Cloud
Jira Work Management Company-managed board

Diagnosis


When loading JWM Board, getting an empty board with the following error:

Failed to load workflow details


Steps to reproduce this:

  1. Update an Issue with a status.
  2. Delete the status. From Jira UI, we can only delete those statuses that are not associated with any workflow. On the other hand, from Database we can delete any status using the following SQL:

  3. Now try to load the issue you updated in step1, due to invalid IssueStatus, the issue will fail to load with the following error message:  
Something's gone wrong

Try refreshing or navigating to another page. If you will see this message, our service might be disrupted.


4. And when you load the JWM Board, it also fails and you see an empty board.

  • When using Splunk, it is possible to encounter a Null Pointer Exception.
   message: [Limited to 100 per PT1H] Exception occurred during doFilter for norm_uri: /rest/issueNav/1/issueTable. 500 status code set for SFX metrics


Cause

It is possible that one reason for the issue is an invalid status. This may occur if one of the Board Issues is linked to a status that is no longer available on the cloud instance.

Solution

  • Check the database for any issues related to the impacted Board and ensure that all of the associated issues are properly linked with valid status.
  • In case you find any invalid entry, please map the respected issue with a valid status id using the following SQL: 



Last modified on Feb 21, 2023

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