Jira Data Center unable to import automation rules from Jira Cloud
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
This article is now deprecated due to an identified Bug and changes in the Cloud and Data Center platforms
Summary
Error during Automation rule import from Jira Cloud to Jira On-Prem
Diagnosis
During the Import process, the error message below is shown
Error parsing provided JSON. Please ensure it was created using 'Export rules' previously. If the problem persists please contact Code Barrel support!
Cause
The problem is caused by the new element in Jira Cloud exports at the end of the file.
Workaround
By editing the JSON file exported from Jira Cloud and removing the code below
"connections":[
{
"id":"6d8300cb-0c00-4b77-9561-95033e025671",
"connectionTargetKey",
"com.atlassian.confluence",
"targetConfigJson":"{\"baseUrl\":\"https://draftkings.atlassian.net\",\"cloudId\":\"266ab7e0-9bb5-4ac4-80ab-c66ba191bc5b\"}",
"authType":"ASAP",
"container"{
"id":"8352004",
"type":"RULE"
},
"createdAt":"2022-08-25T15:28:59.081897Z",
"updatedAt":"2022-08-25T15:28:59.081897Z"}
]
After removing and saving the code, try the import again.