Jira ignores field when creating an issue
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Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When creating an issue in Jira, one or some fields are ignored and always created with the same value regardless of what the user inputted in the create screen.
Environment
All versions of Jira Core 7.x and 8.x.
Jira Cloud.
Diagnosis
Automation investigation
- Browse an issue that was affected by this.
- Click on the History tab, next to Comments, on the bottom of the issue view screen.
- Check if there were any editions to the said field after the issue was created.
Workflow cause
- Open and edit the respective workflow for that issue type in that project.
- On the diagram view, click on the Create transition then on Post Functions.
- Check if there are any Post Functions explicitly setting the field.
Cause
Automation cause
If there's any edition to the issue after the create event, this means there's some automation triggered at the issue creation updating the value.
Workflow cause
If there's a Post Function filling the field on the Create transition, this overwrites whatever value the user inputs in the create screen.
Solution
Automation solution
Check if there are any Automations triggered at the issue creation in global or project scope. Edit them to they don't overwrite the field or fix their conditions to update only the desired issues.
There may also be other 3rd party apps automations causing this. You may fix them accordingly.
Workflow solution
If there's a Post Function overwriting the field, you may remove the Post Function or consider adding a dedicated workflow without the Post Function to that specific issue type.
Some 3rd party apps provide features to overwrite fields if some conditions are met.