New Issues are getting created with Resolution already set
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When creating a new issue in a project, it gets created with a Resolution set as Fixed
Environment
Jira Cloud
Cause
This issue can occur because of the any of the following settings:
- There was a default value set from the system's Resolution section.
- The resolution field was present in the "Issue Create" screen
- The resolution field has been made a required field in the field configuration. When this happens, in order to create issues, they must have a value in that field.
In cases where the Resolution field has been made required by the field configuration, you can't bypass this field when creating issues in that configuration. So either you need to edit the field configuration so that the resolution field is not required or set a value for that field at the time of issue creation. One way to do that would be to set a default value of Resolution or provide its value manually. In the case where there is a default value already set for Resolution, when the user was creating a new issue, it gets created with the set default Resolution.
Solution
We recommend reviewing the more encompassing KB in Best practices on using the "Resolution" field
If the field is not required by the field configuration, then you could remove the Resolution field from the "create issue" screen as a means to prevent end users from adding a value here at creation.