Uninstalled Plugin Warnings Cluttering Jira Data Center Logs

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After uninstalling an add-on, customers may encounter warnings similar to the one below in the Jira logs :

(info) The example below is for JiraMiscCustomFields plugin. 

2023-05-25 09:33:34,279+0200 https-open-nio-443-exec-511 url: /rest/servicedesk/1/USN/webfragments/sections/sd-queues-nav,servicedesk.agent.queues,servicedesk.agent.queues.ungrouped; user: [email] WARN [email] 573x1171007x2 1fcqhg1 192.183.xx.xx:14172,192.168.xx.xx /rest/servicedesk/1/USN/webfragments/sections/sd-queues-nav,servicedesk.agent.queues,servicedesk.agent.queues.ungrouped [c.a.j.plugin.customfield.CustomFieldSearcherModuleDescriptorsImpl] Custom field searcher module: com.innovalog.jmcf.jira-misc-custom-fields:statabletextsearcher is invalid. Null being returned.

Environment

Any version of Jira Data Center
.

Diagnosis

Run the following query in your Jira database to identify if any custom fields are still using the search template from the uninstalled plugin: 

select * from customfield where customfieldsearcherkey like 'com.innovalog.jmcf%';

(info) Adjust the customfieldsearcherkey in the query to match the specific plugin package found in the warning logs.

Cause

There are custom fields using a search template that belongs to an uninstalled plugin, which is causing the warnings in the logs.

Solution

  • Identify Custom Fields:
    After running the SQL query, note down the cfname (custom field name) from the results.

  • Update Search Template:

    • Go to Jira Administration → Issues → Custom Fields.

    • Search for one of the custom field names.

    • Click the three dots (•••) next to the custom field and select Edit details.

    • Change the Search template from the uninstalled plugin to a different, valid search template.

  • Repeat for All Custom Fields:
    (info) Perform the same steps for all custom fields returned by the query.

If the affected custom fields don't appear in Administration → Issues → Custom Fields, it may be necessary to temporarily reinstall the plugin (even if unlicensed) to make them visible again.





Last modified on Mar 19, 2025

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