Upgraded app shows Installed but incompatible in Jira

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Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading a third party app, a message is shown saying the app is "Installed but incompatible".

Diagnosis

Change the logging to DEBUG for the class com.atlassian.plugin and try to upgrade the app.

In the atlassian-jira.log, you can see a message of the following type:

/rest/plugins/1.0/installed-marketplace [c.a.plugin.manager.DefaultPluginManager] Duplicate plugin found (installed version is newer): 'com.xxxx.plugins.xxxx'

Cause

It's unclear what exactly is causing this issue, but it appears that Jira is not able to recognize that the updated version is newer than the currently installed one. As a result, it fails to perform the necessary update.

Solution

Uninstall and reinstall the affected app.


Last modified on Jan 10, 2024

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