How to patch Hipchat Server for CVE-2017-14585

Purpose

Instructions for patching Hipchat Server for CVE-2017-14585.

Compatibility

This patch can only be applied to Hipchat Server versions 2.2.4 and 2.2.5.

For all other versions, please back up Hipchat Server then upgrade to the latest version.

Solution

To patch Hipchat Server:

  1. Log into the Hipchat Server terminal/command-line interface
  2. Download the patch

    wget https://s3.amazonaws.com/hipchat-server-stable/utils/CVE-2017-14585.tar.gz
  3. Decompress the contents

    tar xzf CVE-2017-14585.tar.gz
  4. Change to the patch directory

    cd CVE-2017-14585
  5. Run install.sh

    /bin/bash install.sh

 

Last modified on Jan 19, 2018

Was this helpful?

Yes
No
Provide feedback about this article

Not finding the help you need?

Ask the community

Powered by Confluence and Scroll Viewport.