Configuring Why Button in Jira Align
Summary
This article is to guide you through the process of understanding, setup & troubleshooting the Why? button.
Typical asks are:
Why does the Why? button is not displayed in my instance?
I want to enable the Why? button on the instance
The Why? button information is not synchronized to Jira
I’ve updated the Why? field in Jira but it’s not synchronizing back to Jira Align
Environment
Jira Align
Diagnosis
The Why? button is not displayed; or
The Why? button is not synchronizing
Cause
The Why button functionality might be disabled
The Jira Connector is unable to sync
The incorrect expectation of the Why field’s synchronization behavior.
Solution
How to enable the Why? button functionality (from scratch)
The article View the Jira Align "Why" Field in Jira Software provides comprehensive details on how to enable the Why? button functionality.
The Why? button feature toggle might be disabled
This functionality is controlled by a feature toggle that is disabled by default. Please contact Jira Align Support or a Solution Architect for confirmation and to request enablement.
The Jira Connector is unable to sync
Check with Jira Admin if Jira has a corresponding custom field created for that purpose. That field should be added to the edit & create screens and must be editable. The only supported field type is Text Field (multi-line).
Check if the Jira Connector settings are configured accordingly, with the corresponding custom field ID. Expected format is
Updates in Jira does not sync back to Jira Align
- This is an incorrect expectation of the Why? field’s synchronization behavior. This field is one-direction sync, JA → Jira only (not the other way around)