Jira Align Backoffice service not starting after upgrading to Jira Align 10.127.x
Summary
After upgrading to Jira Align 10.127.x or higher from a version equal to or lower than 10.126.x, the Backoffice service is not starting. This can lead to secondary symptoms such as email notifications not being sent.
Environment
Jira Align Self-Hosted
Diagnosis
The Backoffice service log C:\log\AgileCraft_BackOffice_[CUSTOMER_NAME]-Backbone-<TIMESTAMP> reports the following errors when the Backoffice service attempts to start:
- Email notifications are no longer being sent
Cause
This error is due to the deprecation of AgileCraftServer starting with Jira Align 10.127.x.
Solution
If the Jira Align installation you want to upgrade from has a version lower than 10.127.x (first version in which AgileCraftServer was deprecated), you need to follow the steps to upgrade outlined in Section 3.1 of the Upgrade self-hosted Jira Align instances documentation.
If you have not followed the steps, you can:
Uninstall the existing service with the command:
C:\[ROOT_DIRECTORY]\[CUSTOMER_DATABASE]\BackofficeService\AgileCraft.Backbone.exe --uninstall --task BackOffice --suffix AgileCraftServer
Copy the new AgileCraft.Backbone.exe.config from the source directory (i.e. C:\[ROOT_DIRECTORY]\[CUSTOMER_DATABASE]\Releases\10.127.2.98\Sources\BackofficeService)
Update the connection string:
<add name="Main" connectionString="Data Source=<HOSTNAME>;Initial Catalog=<CUSTOMER_DATABASE>;Integrated Security=False;User Id=<JIRAALIGN_SQL_USER>;Password=<SQL_PASSWORD>;Encrypt=yes;TrustServerCertificate=T rue;MultipleActiveResultSets=True;" />
Re-install the service with the command:
C:\[ROOT_DIRECTORY]\[CUSTOMER_DATABASE]\BackofficeService\AgileCraft.Backbone.exe --install --task BackOffice --suffix [CUSTOMER_DATABASE]