403 - Forbidden error when viewing attachments via portal
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
- Both Customers and Service Management agents are unable to view/download attachments when opening the issue via SD Portal.
- Agents are able to view attachments when using the Jira interface.
The following is seen on atlassian-jira.log:
failed to check if user can view attachment with reason: The request type you are trying to view does not exist.
Cause
The issue doesn't have a valid request type. The request type was deleted or the issue was moved from another SD project in which the Issue/Request type association doesn't match the current SD project.
Resolution
Set a valid request type for the issue. This could possibly require an issue-type change as well.