Activity tab does not loads after opening an issue in Jira
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The activity tab in Jira may not load initially for issues.
Environment
Jira Data Center 9.x
Diagnosis
When opening an issue:
- Activity tab does not loads
- When clicking on issue link, it starts working
- Multiple refreshes does not helps
- Opening issue in new tab does not helps
- HAR would show all responses as fine
- Safe mode does not helps
A similar issue was identified in earlier version of Jira 9.x (before v9.4) and was fixed against:
JRASERVER-74303 - Getting issue details... STATUS
However, there are reports of problem in the version above fixed versions
Workaround
We do have couple of workarounds as below:
Workaround 1
Disabling the Lazy load via Dark Feature
- Refer to How to manage dark features in Jira and disable this feature
- Feature flag name: com.atlassian.jira.lazyload.activity.tabs
- Navigate to <BASE_URL>/secure/admin/SiteDarkFeatures!default.jspa
- Enter com.atlassian.jira.lazyload.activity.tabs.disabled in the Enable dark feature section.
- Click on Add.
Workaround 2
Add the following HTML snippet script in the announcement banner