After adding a new column it does not appear in the Jira issue navigator

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Problem

After adding a new column in the issue navigator as per Configuring issue table columns, it does not appear when performing a search.

Cause

This may be the expected behaviour, as some custom fields are restricted to a certain Issue Type, or if they are project-specific as detailed in the troubleshooting section of Configuring issue table columns.

Workaround

A successful workaround regarding this behaviour is using the '!=' argument on an unrelated issue-type. To do this:

  1. Identify an issue type not currently in use for your project, alternatively create a new issue-type for this specific purpose.
  2. Generate your original query using Advanced searching and add the following:

    issuetype != <issuetype not in use>

    (info) The query results will contain the selected Issue Navigator custom-field column alongside all other issue types.  This workaround also continues to work for the exporting of the document.

Resolution

  • Restrict your search.
  • Project-specific custom fields: The added column will appear if the search returns only issues that belong to that project.
  • Issue Type-specific custom fields: The added column will appear if the search returns only issues that belong to that issue type.

Last modified on Apr 26, 2021

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