After Upgrading JIRA presented with JIRA Access Constraints warning

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Problem

Following an upgrade to JIRA, when accessing JIRA, the following message is shown:

JIRA Access Constraints, The current license is too old to install this version of JIRA.

The following appears in the atlassian-jira.log

2015-05-17 01:01:01,001 localhost-startStop-1 ERROR      [atlassian.jira.license.LicenseJohnsonEventRaiserImpl] The current license is too old (01/JAN/15) to run this version (6.4.4 - Mon May 11 00:00:00 EDT 2015) of JIRA.

Diagnosis

Diagnostic Steps

  • Log onto my.atlassian.com and check the relevant License, and SEN for this JIRA instance. 

Cause

This can be caused by Upgrading JIRA without a valid JIRA License - you cannot upgrade JIRA to any versions that are released after the date in which your JIRA license expires. As per the Upgrade JIRA Documentation a check to validate your JIRA license is recommended before upgrading. 

Resolution

To resolve this, renew your license, and follow the link to "Edit License or proceed under Evaluation Terms"

Last modified on Nov 1, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.