Alerts created via Zabbix integration shows Default API as the name of integration
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
The Source field in an Alert created via Zabbix integration shows Default API instead of Zabbix integration and also ignores the filters in the Zabbix integration.
Environment
- Opsgenie
- Zabbix v.5.0 or higher
Diagnosis
There are two options to integrate Zabbix and Opsgenie:
An integration offered by Opsgenie
This is offered by Opsgenie and it uses a separate plugin to send alerts from Zabbix to Opsgenie. This sends payloads from Zabbix to the /v1/json/zabbix endpoint with a specific format.
An integration offered by Zabbix
This is owned by Zabbix and is now available natively in Zabbix. This was built using Opsgenie's public Alert API endpoint /v2/alerts.
You will see alerts using “Default API” as the source integration when you setup integration using Option#2 from the above.
The Zabbix integration in Opsgenie is intended to be used with Option#1 from the above.
Solution
The solution is to align on which configuration you want to use, and ensure the instructions for that method are being followed:
If you want to employ OEC, or want to use the Opsgenie-provided plugin to be able to use the alert filters and send actions back to Zabbix, then follow the instructions given in Integrate Opsgenie with Zabbix Plugin.
If you want to integrate Opsgenie with an integration that comes with Zabbix and don't have a need to send actions back to Zabbix, follow the instructions given in integration built by Zabbix using a generic API integration:
If you still encounter issues or need more clarification on the above topic, consider reaching out to Atlassian Support for further assistance.