Apps disabled with Wrong Type license error in Jira Software

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Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After updating the Jira license or upgrading the Universal Plugin Manager Add-on, one or more Add-ons are disabled. When reviewing the Add-ons in the Universal Plugin Manager, the text "Incompatible with Product License (wrong type)" is displayed in the License Status field.

Diagnosis

  • License tiers and types match across Jira and any Add-ons that are installed, but Add-ons are turned off with the message "Incompatible with Product License (wrong type)."

Causes

  • The Jira license is changed from the Commercial type to the Enterprise Commercial type

  • An update of the Universal Plugin Manager introduces a new rule that causes the licenses to be incompatible.


The cause of this is the use of licenses that disagree with Type. For example, there is an Enterprise license type available that the Universal Plugin Manager 2.7+ will verify that it is compatible with any Add-ons in Jira.

Workaround

If it is critical to get the app operational before Atlassian Sales can mint a new license key, please go to your my.atlassian.com account and generate an Evaluation license.

Resolution

Depending on the cause, the fix will be different. Please ensure the following:

  • If you're using a developer license for an app, make sure you also use a developer license in Jira so the license types are compatible. 
  • Update the UPM to the latest compatible version available to the version of Jira you are running. 
    • There have been bugs with the compatibility checks on licenses being too restrictive, which were resolved in later versions of the UPM.
  • If you notice your licenses are incompatible, please get in touch with Atlassian at sales@atlassian.com for assistance in converting them.


Last modified on Jan 24, 2025

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