Assets Custom Fields are not showing up in a JSM Notifications email
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
JSM email notifications cannot include Assets custom fields.
Cause
Even though Assets (previously known as Insight) was acquired by Atlassian, it is still not fully integrated into JSM, particularly email notifications. In this regard, Assets custom fields are still considered third party add-on custom fields.
In our Managing service project notifications documentation, there is no placeholder available for any custom field - Only Issue Fields can be included in the Customer notification:
Request details | ${request.details} | The full details of a request. This includes the creation date, request type, summary, and the same fields configured as visible in the request type setting. This does not include fields created by third-party add-ons. |
There is an existing suggestion ticket JSDSERVER-4642: Ability to add custom field data to a service desk notification template that you can vote and watch on for allowing custom fields to be included in JSM email notifications.
Workarounds
- JSM customer notifications include the issue's URL. As long as the recipient has appropriate permissions, clicking on the link will allow them to access the browse issue page and see all visible custom fields. Assets custom fields however, will only allow the Object Label to be visible.
- Alternatively, Assets custom field value may be sent separately using the Insight postfunction: Email users based on attribute in selected object.