"Attach Screenshot" doeesn't work in Internet Explorer and re-directs to JAVA downloads website

Still need help?

The Atlassian Community is here for you.

Ask the community


Symptoms

JIRA applications 'Attach Screenshot' tool fails to load, instead the pop-up window re-directs to Oracle website

Diagnosis

  • The client machine already has java properly installed and enabled.
  • Occurs when using the Screenshot tool in Internet Explorer 11 despite having java enabled in the browser, however the tool works fine with other browsers on the same machine.
  • Affects JIRA 6.1.x and above

Cause

The issue may be related to a bug that occurred in JIRA 6.1.x:  JRA-36416 - Getting issue details... STATUS . This bug however has been fixed in JIRA 6.2.

Workaround

  1. Use the Attach Image for JIRA plugin instead (not available for OnDemand customers)
  2. Try using another browser with Java enabled e.g Chrome, Firefox
  3. Using IE developer tools use the emulator tool to change the 'User Agent String' to 'Internet Explorer 10'.

Resolution

  1. Upgrade the JIRA installation to JIRA 6.2
  2. If the issue persists in JIRA 6.2 you may need to re-install java on the client machine:
    1. Start Internet Explorer.
    2. Navigate to this link and download java - http://java.com/en/download/ie_manual.jsp

      tip/resting Created with Sketch.

      Download java again even if you have it installed

    3. Re-install Java.
    4. Try Attach Screenshot again.

Last modified on Nov 16, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.