Attachment field is not appearing on Customer Portal when creating new requests

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

You've added Attachment field to a Request Type, but customers don't see the field when creating a new request of that Request Type:

Diagnosis

Check the followings from Project settings of the Service Management project:

  1. From the Field Configuration used by the issue type associated with the request type, is Attachment visible or hidden? If hidden, Show it.
  2. From the Create Issue Screen used by the issue type associated with the request type, is Attachment available? If not, Add it to the screen.
  3. From Request Types -> Edit fields, if you Remove Attachment from the Visible fields list, can you Add it back again right after that, or will it become missing from the list of available fields for addition?
  4. From the Permission Scheme of the project, how is the permission Create Attachments configured? Do you get any warning about the permission configuration when administering the Service Management settings of the project?
  5. Do you see Attachment field on any other screen in Jira?

Cause & Resolution

Attachments is disabled in the System settings? It must be enabled from Jira Administration -> System -> Attachments for the field to be visible.

A more generic KB on missing fields on screens can be found at Fields missing on screens in Jira server.

Last modified on Nov 23, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.