Automatic issue creation from Slack is not working in JSM Chat

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

   

Summary

You can turn on automatic issue creation in request channels, which removes a step for your agents and requesters. This means that Assist turns any message posted in a request channel into an issue and adds a lightning emoji (:lightning:) to the message to indicate automatic issue creation.

Even though Automatically create issues from messages option is enabled under Chat settings, the requester receives an automatic prompt in Slack to raise the request.

Environment

Jira Service Management Cloud

Diagnosis

You can follow the below steps to turn on automatic issue creation as a Jira admin:

  1. From your service project sidebar, select Channels, then Chat, then Configure.

  2. From the Slack tab, find the request channel you’d like to manage. Select the header or pencil icon to open the settings.

  3. Check Automatically create issues from messages.

  4. Select Save changes.

If any fields for the request type are required, the requester receives an automatic prompt to fill them out. If no fields are required, the message should turn into an issue automatically as soon as it’s posted but receives an automatic prompt in Slack to raise the request.

To add or remove required fields, you can customize the request type.

Cause

The prompt appears in Slack when there is more than one request type configured under Project settings > Chat > request types Chat settings and you enabled Automatically create issues from messages option. It works fine if there's only one request type added in the Chat settings.

Solution

When you enable Automatically create issues from messages option, you need to also enable and select one request type under Associate request types with this channel if there is more than one request type added in the Chat settings.

Last modified on Jul 18, 2023

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