The Boards navigation button missing from the top bar menu in Jira

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

 

Problem

The board tab which comes from Jira Software has gone missing:


Normally, the board tab should be showing in the top bar menu, as shown in the screenshot below:

Environment

Jira Software Data Center on any version from 8.0.0.

Cause

There are several possible causes for the issue:

  1. You have recently upgraded Jira Software and then downgrade the version instead of rolling back a Jira upgrade
  2. The user that logged into Jira does not have Application Access to Jira Software
  3. The number of users who are allocated Jira Software Application Access is higher than the actual number of Jira Software licenses
  4. No users can see Boards tab, in which case, the Jira Software application has failed to load up during the startup of Jira
  5. Expired license. An expired Jira Software License has limited access towards Agile functionality:
  6. Jira version incompatibility between Jira Core and Jira Software

Resolution

Cause 1

Follow the instructions in "Jira Software is currently unavailable" error after upgrading to Jira 7 or newer KB article. 

Cause 2

  1. Login in to Jira with any user that has Jira Administrator global permission.
  2. Navigate to > User Management > Users.
  3. Look the impacted user in this page, and check if the Jira Software application is missing from the Applications column for this user, as shown in the screenshot below. If that's the case, then this root cause is relevant:
  4. In this case, you will need to add the user to a group which grants them Jira Software application, as shown in the page ⚙ > Applications > Application Access.

Cause 3

  1. Login in to Jira with any user that has Jira Administrator global permission.
  2. Navigate to > Applications > Versions & Licenses.
  3. Check if the used number is higher than the users number.
  4. If it is higher as shown in the screenshot below, then this root cause is relevant:
  5. In this case, you will need to either upgrade the Jira Software license to the next user tier, or remove licenses from users who no longer need it.

Cause 4

Review the $JIRAHOME/log/atlassian-jira.log file and look during the startup of Jira to see if any plugins failed to load (You can search for the string "FAILED PLUGIN REPORT").  If JIRA Software fails to load during this point it could be due to a version incompatibility, or simply insufficient resources.

If the version is incompatible, you can correct this by going to:

  1. Login in to Jira with any user that has Jira Administrator global permission.
  2. Navigate to  > Applications > Versions & Licenses
  3. There should exist the option to update Jira Software here directly

If the version is compatible, it is possible that one or more system plugins has been disabled in the database level,

  1. Review the steps in Increasing Jira memory to make sure your Jira application is set to use enough memory (Xmx) to load all your plugins.  If you are not sure how much that should be, check our Jira Sizing Guide reference doc.
  2. Follow the steps in Jira application does not start due to disabled bundled plugin to correct this
  3. Restart Jira

Cause 5

Renew the Jira Software License.

Cause 6

Jira Core is the base installation for Jira and Jira Service Management are applications on top of Jira Core. When these applications are upgraded directly from the user interface without upgrading Jira Core, it may lead to compatibility issues.

To fix the compatibility issue, Jira Software has to be re-installed. Steps outlined are below:

  1. Stop Jira
  2. Create a copy of <JIRA-Home>/installed-plugins directory outside of <Jira-Home> (or <Jira-Shared-Home> in case of Jira Data Center with multiple nodes)
  3. Navigate to <JIRA-Home>/installed-plugins and delete all the jar files starting with jira-software and  jira-greenhopper-plugin
  4. Start Jira

Next navigate to Administration > Applications > Versions & License Page
It will prompt Jira Software is licensed but not installed. Click on install button on the UI to install Jira Software


Last modified on Jan 17, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.